[En-Nut-Discussion] amontec jtagkey and openocd not working

Martin Ludwig mludwig at adc-elektronik.de
Sat Jul 29 15:29:43 CEST 2006


is there anybody out there who uses the Ethernut3 Board together with
the amontec jtagkey and openocd.
i´ve tried many things to get it work (michael fischer try to help me) ,
but it still doesn´t work.
openocd and the jtagkey are working together, the signals i´ve measured
up  to the cpu pin´s.
but openocd tell´s me

jtag.c:981 jtag_read_buffer(): value captured during scan didn´t
pass the requested check captured 0f check_value: 01 check:mask: 0f
and than Taget was alread halted.

when i type the poll command in the telnet-window the 5 Lines show´s
nice digital patterns but i don´t know how to read them.

when i try the insight debugger i got the message "cannot reset the board"
and in the openocd window i see "warning dropped gdb connection"

i tried some availiable versions of drivers, toolchain , openocd etc. 
but the
things doesn´t change.

The TDO Signal is really strange with the amontec key it is like a
ballistic curve. I put a pullup (10k) then it is ok.

With turtelizer i can flash the board so the ethernut3 seem´s to be ok.

BTW : my last time problem with tftp is not solved but moved , i tried 
pc standalone with a 100 MBit Adapter then the programming with tftpd 
works -
but it tooks time some 10´s of seconds. On the orginal PC i´ve some 10 MBit
Maschines on the network. May be it´s the problem.

thank´s for any hints

Martin Ludwig


Sehr geehrte

Mit freundlichen Grüßen
Martin Ludwig
Dipl. Informatiker
Geschäftsführer BDE-Systeme

ADC-Elektronik Graner & Ludwig oHG
Alleestasse 56
59065 Hamm
Tel +49 2381 59471
Fax +49 2381 57853

Besuchen Sie unsere Homepage www.adc-elektronik.de
Fernwartung / Vorführung starten Netviewer

More information about the En-Nut-Discussion mailing list