[En-Nut-Discussion] flashing programm on Ethernut 3 doesn´t work

ml mludwig at adc-elektronik.de
Sat Dec 8 15:19:19 CET 2007

i have a problem with 2 Ethernetboards Rev D , E.
I tried to flash both boards with openocd and turtelizer2
but it doesn´t work. In telnet i type in the
flash erase command - doesn´t work. The flash probe command 
shows flash at 0x10000000. 
At the D-board the -flash probe- command works most of the time, 
at the E-board most of the time it doesn´t. 
(Even debugging with insight or eclipse on the E board is most of the time

So i took my old turtelizer and try to flash the boards so
they will have the same programm. Perhaps the different behaviour
depends on the different programms in the flash of the boards.
(I don´t now why it can be but i wan´t to try out)

But Turtelizer don´t work. i tried to update firmware to 1.25
- same mistake.  Some month ago i programmed the boards
with turtelizer without any problem.

That´s the output of jtagomat 


C:\ethernut-4.4.0\nut\tools\win32>jtagomat -v -DDEVICE=0x1F0F0F0F BATCH
JTAG-O-MAT 1.2.5
Turtelizer at COM1
Turtelizer 1.2.5
at91-erase.jom(1): RESET
at91-erase.jom(2): HALT
at91-erase.jom(3): DEVICE 0x1F0F0F0F
Target ID = 1F0F0F0F
at91-erase.jom(4): ONERR Error
at91-erase.jom(6): LOAD 0xFFE00000
at91-erase.jom(7): LOAD 0xFFE00004
at91-erase.jom(8): LOAD 0xFFE00008
at91-erase.jom(10): ; Remap
at91-erase.jom(11): SAVE 0xFFE00000 0x1000213D
at91-erase.jom(12): SAVE 0xFFE00020 0x00000001
at91-erase.jom(14): FLASH 0x10000000


Sometimes jtagomat breaks because target ID is 0xFFFFFFF

Flash isn´t erased and the programms on the boards (bootmon in the D-board)
(my on programm in the new E-board) are still working.

thanks for any help.

View this message in context: http://www.nabble.com/flashing-programm-on-Ethernut-3-doesn%C2%B4t-work-tf4967055.html#a14228638
Sent from the MicroControllers - Ethernut mailing list archive at Nabble.com.

More information about the En-Nut-Discussion mailing list