[En-Nut-Discussion] Can't correctly build NutOS 4.8.9 on Fedora 14 for Ethernut 2.1b

Bernard Fouché bernard.fouche at kuantic.com
Mon Apr 18 17:46:41 CEST 2011

Hi Harald,

It can be the environment: I run lua 5.1.4-7 instead of a 5.0.Y. Since 
the manual says that 5.1 does not work (without more details) and that 
lua is 'required to parse configuration files', I made a few try in this 
direction because when I run 'make all' into ~/ethernut/nutbld, all the 
avr-gcc options you show are missing:

[bernard at linuxbf2 nutbld]$ make all
make -C arch
make[1]: Entering directory `/home/bernard/ethernut/nutbld/arch'
avr-gcc    -c -o avr/os/context_gcc.o 
/home/bernard/ethernut/nut/arch/avr/os/context_gcc.c:114:20: error: 
cfg/os.h: No such file or directory

There are spaces between 'avr-gcc' & '-c' like some options values where 
replaced by an empty space.

To have ./configure to understand I use a particular version of lua (I 
compiled & installed 5.0.3 in /usr/local), I tried:

$ export LUA_EXEC=/usr/local/bin/lua ; ./configure

it gave the same result (after having re-installed NutOS from scratch as 
I do each time...)

I also tried 'chmod 0 /usr/bin/lua ; chmod 0 /usr/lib/liblualib-5.1.so 
;' and then './configure'. Again the compilation in 'nutbld' gives the 
same results.

What do you have in ~/ethernut/nutbld/NutConf.mk ? Here I just have:
# Automatically generated on Mon Apr 18 17:42:10 2011
# Do not edit, modify UserConf.mk instead!


include $(top_blddir)/UserConf.mk

Hence I don't understand how avr-gcc could be aware of all the command 
line options that you show when you build on your computer, it seems 
that running lua 5.0.3 or 5.1.4 is not the explanation of my problem.


More information about the En-Nut-Discussion mailing list