[En-Nut-Discussion] External Ram problem in Ethernut1.3H

Ayman Hendawy ayman.hendawy at gmail.com
Sat Dec 1 17:16:27 CET 2012


I applied wrong voltage on the board "VCC" pin of "J5" my mistake, so I
burned the External SRAM, and Ethernet chip "RTL8019AS", so I changed RTL
chip and it working fine, and for the external SRAM, I have changed both
"K6X0808C1D-BF55" with "K6X0808C1D-BF70", and buffer TI "AHC573" with ON
semi "HC573A", but I found that the SRAM is not working.

When I run basemon, I get that message "External RAM Test... 0 bytes", when
I pressed "S- SRAM Read/Write", I get nothing and when I pressed any key it
print "No RAM at at 0x8000".

I tried to access the SRAM using some functions in the xmemtest.c of
basemon, as following,
printf("1st readed data = %d", MemRead(0x1107));              // here I try
first to read location address 0x1107, it print out on screen 1799
MemWrite(0x1107, 7777);
//here I write on the same address 7777
printf("2nd readed data = %d", MemRead(0x1107));       // then I read the
same address again, it print out on screen 1543
when I repeat the above steps many times it print the same value, which is
1543, which mean I succeed in write and read from SRAM, and read the same
data many times, but I can't understand why I can't read the same value
that I have written "7777".

Do any one have some helping steps how to check the SRAM,and get it working?

Best regards

Ayman Hendawy
Embedded system engineer


Phone: +20110406659

More information about the En-Nut-Discussion mailing list