[En-Nut-Discussion] Nut/OS ARM eCross-EABI toolchain

Ole Reinhardt ole.reinhardt at embedded-it.de
Fri Jun 8 16:37:14 CEST 2012

Hello Dieter,

> Now I have installed the new Kubuntu 12-04 LTS, and have big problems,
> and I need some help.

> But toolchain does not build, because arm-eCross-eabi-gcc is not recognized.

Ok, it seems that the compiler is not found in the search path.

> The path in .bashrc is set for gcc:
> export PATH=$PATH:~/arm-eCross-eabi/bin

In general this looks ok to me, but I suppose that the .basrc is not
evaluated when calling the compiler from within the qnutconf.

You could try to open qnutconf from within a terminal window.
Anyway you have to logout and re-login first after the changes
of .bashrc take effekt.

If you want to be sure:

Just add the same line at the end of 


(writable by root only, so edit it with root privileges)

> I think the binaries will not be accepted.

Have you tried to call the compiler by hand from within a terminal


~/arm-eCross-eabi/bin/arm-eCross-eabi-gcc --version

If it does not start:

Are the attributes set correctly (the x-bit set for the user / group?)?
This should be ok, when just extracting the archive with tar.

Later down I see that you are using a 64bit system. The toolchain is
compiled for 32bit systems. Have you installed the 32bit compatibility
layer / libraries? Perhaps there is any library missing?

> I have downloaded the Sourcen ARM eCross EABI Toolchain-Builder inkl. 
> Patches 
> <http://www.embedded-it.de/bsp-download/arm-eCross-eabi-source-2011-02-02.tar.gz>
> and try to compile.
> Unfortunately, there is an error message.

> ---- Building gmp ------
> configure: error: could not find a working compiler, see config.log for 
> details

Have you just look into the config.log file? (which should be placed
anywhere in the build tree?)

If you can't find it try a 

find . -name config.log

> Is there someone who could help me a little bit to solve the problem.

Please let me know if any of the above hints could help you.

I did not yet tried to compile the toolchain on a 64 bit system, as we
still have all our systems installed as 32 bit system.

If you can _not_ start the binary directly by calling 


from within 


then please call

ldd ~/arm-eCross-eabi/bin/arm-eCross-eabi-gcc  

and send me the output. I can than tell you which libraries are missing
on your system and should be installed.

Best regards,

Ole Reinhardt


Thermotemp GmbH, Embedded-IT

Embedded Hard-/ Software and Open Source Development, 
Integration and Consulting


Geschäftsstelle Siegen - Steinstraße 67 - D-57072 Siegen - 
tel +49 (0)271 5513597, +49 (0)271-73681 - fax +49 (0)271 736 97

Hauptsitz - Hademarscher Weg 7 - 13503 Berlin
Tel +49 (0)30 4315205 - Fax +49 (0)30 43665002
Geschäftsführer: Jörg Friedrichs, Ole Reinhardt
Handelsregister Berlin Charlottenburg HRB 45978 UstID DE 156329280 

More information about the En-Nut-Discussion mailing list