[En-Nut-Discussion] Problem to program Ethernut 1.3G

Philippe Kieffer philippe.kieffer at free.fr
Tue Mar 6 18:00:48 CET 2012

Hello everybody,

I bought a Ethernut 1.3G in 2006.
I realised an embedded http server, which works very well for monitoring a few installations in my house.
Today i want to modify this server.
I tried to program the board with SP Duo and AVR Studio 4.12. The software finds the SP Duo, but can't enter programming mode.
I tried with stk500.exe and the command line :
stk500 -cCOM1 -dATmega128 -e        (for erasing)
The resut is :
STK500 command line programmer, v 2.0 Atmel Corp (C) 2004.
Connected to STK500 V2 on port COM1
Device parameters loaded
Could not enter programming mode
Programming mode left
Connection to STK500 V2 closed
WARNING! One or more operations failed! Please examine the output log above!

The result is the same with SPI or JTAG connector.
I precise that I never programmed the fuses...
I tested the communication with the SP Duo, with Hyperterminal : when I send ctrl + v, he says : SP Duo v2.2

Thanks you on advance for your help.

More information about the En-Nut-Discussion mailing list