[En-Nut-Discussion] DEV_XXX_NAME versus DEV_XXX.devname
bon at elektron.ikp.physik.tu-darmstadt.de
Mon Sep 24 14:11:54 CEST 2012
in a lot of files additional to the definition or usage of DEV_XXX, there is
also definition and usage of DEV_XXX_NAME. I think these definitions are
redundant as DEV_XXX_NAME can also be written as DEV_XXX.dev_name. These
redundants definitions clutter the code and there is a chance that they get
out of sync. Is there any reason of the usage of this redundant definition?
If I don't hear back, I am going to remove all DEV_XXX_NAME definitions and
replace all references to DEV_XXX_NAME with DEV_XXX.dev_name in the next
I already did with DEV_CONSOLE_NAME in the nut/app/* directories.
Uwe Bonnes bon at elektron.ikp.physik.tu-darmstadt.de
Institut fuer Kernphysik Schlossgartenstrasse 9 64289 Darmstadt
--------- Tel. 06151 162516 -------- Fax. 06151 164321 ----------
More information about the En-Nut-Discussion