[En-Nut-Discussion] IH Macro for CM3

Harald Kipp harald.kipp at egnite.de
Tue Nov 26 16:50:28 CET 2013

On 26.11.2013 13:31, bon at elektron.ikp.physik.tu-darmstadt.de wrote:
>>>>>> "Harald" == Harald Kipp <harald.kipp at egnite.de> writes:
>     Harald> Minor issue: To be able to distinguish separate words, Nut/OS
>     Harald> function names are typically CamelCase, while variable names use
>     Harald> underlines. Do you think we should change this to Camel_Case?
>     Harald> Nut/OS macros are all upper-case with underlines between
>     Harald> words. Any reason to change this?
> Is CreateHandler() a function or CREATE_HANDLER() a macro? Please advise
> what I should use.

I updated


a bit, specifically the chapter "More about naming conventions" near the
end of that page. I hope it is intelligible to all.



More information about the En-Nut-Discussion mailing list