[En-Nut-Discussion] Build Ethernut tools using a recent version of Lua

Philipp Burch phip at hb9etc.ch
Tue Feb 6 11:49:27 CET 2018

On 06.02.2018 11:08, Uwe Bonnes wrote:
>>>>>> "Philipp" == Philipp Burch <phip at hb9etc.ch> writes:
>     Philipp> Hi everyone, whenever I want to setup the Ethernut build tools
>     Philipp> on a new machine, I'm stuck for a while with the configure
>     Philipp> error "No package 'lua' found".  Right now, I'm trying to get a
>     Philipp> copy of Lua4 for my notebook running Ubuntu 16.04. But
>     Philipp> actually, I'm not even sure which version actually is
>     Philipp> required. Are there any plans to update the Ethernut tools to
>     Philipp> work with a recent Lua version that is in the usual distro
>     Philipp> packages (>=5.0)? In any case, I'd be glad if the configure
>     Philipp> script could output the required version in addition to the
>     Philipp> package name.
> Did you try the cmake files. They have a version of lua intergrated as
> fallback?

Hi Uwe,

actually no, but that's good to know. What would be required to set so
that the configure script (or pkg-config) actually finds this
manually-compiled version of lua? Does it "just work"? I'd rather not
try, as my installation now works...

Thanks and best regards,

More information about the En-Nut-Discussion mailing list