[En-Nut-Discussion] Basic loading of nut/OS applications via TFTP

Nikolas Becker N.Becker at pemtec.de
Mon Jul 23 14:30:52 CEST 2018


tl;dr: If I run tftpbootnut in u-boot, nothing happens besides seemingly correct setup. What am I doing wrong?

We plan to use the ethernut5-board in an industrial application. For development, we bought one unit from egnite. I try to get started with the Nut/OS development, but fail to start the example projects. I compiled several examples (simple, httpd, httpd_simple) and installed a tftp-sever (tftpd64). I was able to receive the .bin files from another PC in the network, so my server seems ok. I tried to follow the u-boot environment guide for loading nut/OS applications.

What I did in u-boot:
run setfactory
setenv ethaddr 00:06:98:50:00:CA
setenv nut_image_name httpd.bin
run tftpbootnut

U-Boot is responding with:
macb0: PHY present at 0
macb0: link up, 100Mbps full-duplex (lpa: 0xcde1)
BOOTP broadcast 1
DHCP client bound to address

And that's all. Shouldn't Nut/OS now post at least something? Of course, in my tftp-server directory, a file named httpd.bin is present. What am I doing wrong? Please help me getting started ...

Mit freundlichen Grüßen
Sincères Salutations

Best regards

Nikolas Becker
Dipl.- Physiker


6 rue Jules Verne
BP 60147
57603 Forbach Cedex

Tel.:    +33 (0) 387.13.09.22
E-Mail: n.becker at pemtec.de

Dipl.-Ing. Hans Wacht
SNC au capital de 10 000 000 euros
RCS Sarreguemines B 450 696 752
Code APE 2841 Z

More information about the En-Nut-Discussion mailing list