[En-Nut-Discussion] Error trying to make Nut examples

David Corder david.corder at ntlworld.com
Sun Nov 10 11:46:20 CET 2002

I've got a v1.1 Ethernut board which I'm trying to set up to experiment with
but I seem to be doing something wrong with the compiler set up.  I've
installed "avrgcc_freaks20011214a.exe" followed by "nut252c.exe" and
"nut252d.exe" which I put into a nut directory under the avrgcc directory.
I have edited nutenvgc.bat to set the target processor to atmega103 and to
point to the correct nut directories.  Opening a DOS window I run nutenvgc
which runs successfully as far as I can see.  Unfortunately when I type make
in any of the app directories I get the following (simple used in this

avr-gcc -c -mmcu=atmega103 -Os -Wall -Wstrict-prototypes -Wa,-ahlms=simple.l
st  -IC:/avrgcc/nut/include simple.c -o simple.o
simple.o -mmcu=atmega103 -Wl,-Map=simple.map,--cref -LC:/avrgcc/nut/lib/gcc/
atmega103  C:/avrgcc/nut/lib/gcc/atmega103/init.o -lnutos -lnutdev -o
C:/avrgcc/nut/lib/gcc/atmega103/init.o: Relocations in generic ELF (EM: 83)
C:/avrgcc/nut/lib/gcc/atmega103/init.o: could not read symbols: File in
wrong format
make:  *** [simple.elf] Error 1

Any suggestions would be welcome.  I'm running this under XP but tried the
same installation process under 98 with the same problems.  I've tried Make
Clean, this works without any errors.


More information about the En-Nut-Discussion mailing list