[En-Nut-Discussion] Nut don't work anymore

Hugo Simon hugo.simon at gmx.de
Tue Jul 4 20:43:11 CEST 2006

Help please!

I tried the new 4.1.9 version, and now my Nut doesn't do anything anymore.
Even if I downgrade to my previous installation 4.1.3.

I tried compiling/flashing basemon and httpd samples. Both compile without
errors, but the Nut shows no signs of life. Only the red powerlight comes
up, nothing else. No serial output, no carrier led from the Ethernet
controller. But flashing and verifying is ok.

Any idea what happened. Maybe someone can send me a precompiled basemon or
so to check if it is a hardware problem. I have the Ethernut 2.1 board.

What I think is a bit irritating, in the compile output (see below) it seems
both network drivers are linked, the realtek and the smsc. Is that ok?

Thank you

avr-gcc -c -mmcu=atmega128 -Os -fno-delete-null-pointer-checks -Wall -Wstric
ototypes -Wa,-ahlms=basemon.lst -DETHERNUT2 -D__HARVARD_ARCH__ -Ic:/entwickl
ernut-4.1.9/nutbld/include  -Ic:/entwickl/ethernut-4.1.9/nut/include
-o basemon.o
avr-gcc -c -mmcu=atmega128 -Os -fno-delete-null-pointer-checks -Wall -Wstric
ototypes -Wa,-ahlms=xmemtest.lst -DETHERNUT2 -D__HARVARD_ARCH__ -Ic:/entwick
hernut-4.1.9/nutbld/include  -Ic:/entwickl/ethernut-4.1.9/nut/include
c -o xmemtest.o

More information about the En-Nut-Discussion mailing list