[En-Nut-Discussion] Nut don't work anymore

Harald Kipp harald.kipp at egnite.de
Wed Jul 5 17:42:34 CEST 2006

Hello Thorsten,

A pre-compiled Basemon is available with the standard Nut/OS
distribution for Windows. Look at nut/app/bin/atmega128.

If you're using Linux, get it from www.ethernut.de/arc
I just uploaded it there.

Yes, the Basemon binary runs on Ethernut 1 and 2 and thus
contains Ethernet drivers for the RTL8019 and the LAN91C111.


At 20:43 04.07.2006 +0200, you wrote:
>Help please!
>I tried the new 4.1.9 version, and now my Nut doesn't do anything anymore.
>Even if I downgrade to my previous installation 4.1.3.
>I tried compiling/flashing basemon and httpd samples. Both compile without
>errors, but the Nut shows no signs of life. Only the red powerlight comes
>up, nothing else. No serial output, no carrier led from the Ethernet
>controller. But flashing and verifying is ok.
>Any idea what happened. Maybe someone can send me a precompiled basemon or
>so to check if it is a hardware problem. I have the Ethernut 2.1 board.
>What I think is a bit irritating, in the compile output (see below) it seems
>both network drivers are linked, the realtek and the smsc. Is that ok?
>Thank you

More information about the En-Nut-Discussion mailing list