[En-Nut-Discussion] Ethernut1.3H Hardware problem

Ayman Hendawy ayman.hendawy at gmail.com
Mon Jan 14 19:25:23 CET 2013


I have post this problem before, and unfortunately I still can't fix it
till now,
My Ethernut1.3H board has get an over voltage which burn the Ethernet chip,
the buffer, and the External SRAM, I have changed all of this chips with
new ones, also I have tested my board espicially the *uC* on oscilliscope
and and the buses signals output fine from uC, I just add two pull up
resistors to PORTC, because it seam that the internall pullup resistors of
two pins burned,
now when I run the Basemon code test I get the following output,

BaseMon 4.2.0
Compiled by AVRGCC for ATmega128
Baudrate select = 95
External RAM Test... 28416 bytes
Banked RAM Test...   none
Serial FLASH...      0 bytes
Detecting NIC...     RTL8019AS
Testing NIC...       OK
I/O Port Test...     OK

The Problem now is that* *when I run the Web Server of the basemon
application, it open with no problem, but it seam to work very slow not
like in the past, when I first buy my board, opening any link on the
webserver open after too much time ( like press, List
 List timers <> List
 I/O ports <> ).

Also, when I run the test code"
I get an error message of "104 Bad jumper mode", I don't know what does it
mean or if my Ethernet port is working probably or not, it seam not.

When I run my main application which also use webserver (not basemone), it
configure the network, then I found the application freeze, I don't know
why, and also sure that the used code was working fine, because it have
took a backup of it when at the problem happen at the beginning.

Any suggestion?


Best regards

Ayman Hendawy
Embedded system engineer


Phone: +20110406659

More information about the En-Nut-Discussion mailing list