[En-Nut-Discussion] Moving NutCondition, NutMsgQ, NutMutex and NutSem
harald.kipp at egnite.de
Mon Jan 13 10:05:16 CET 2014
On 12.01.2014 23:43, Ole Reinhardt wrote:
> gorp... I never was really convinced by this name for the "gimmick" library.
> I'd like to suggest to rename the whole directory to "lib", or something
> else more meaningful and fill up its directories with more commonly
> needed code over the time.
What funny suggestion is this? Nut/OS itself is already a lib. Adding a
new "lib lib" is totally confusing.
If Uwe would have googled for "gorp library" and if the documentation
would be a bit more advanced (telling him to add -lgorp to his
Makefile), then he wouldn't have to ask.
> The I would vote to do both: Move the mentioned implementations _and_
> fix them.
The request was about moving, not fixing. Fixing and enhancing parts is
> I would even suggest to try to reach libpthread compatibility in the
> future (also by providing wrapper functions in the pthread syntax if
> possible). This would help porting further third party libraries to Nut/OS.
I was in doubt whether pthread would fit on top of a cooperative
scheduler. But obviously this is possible, see
More information about the En-Nut-Discussion