[En-Nut-Discussion] Build Ethernut tools using a recent version of Lua
phip at hb9etc.ch
Tue Feb 6 10:42:37 CET 2018
On 06.02.2018 09:50, Philipp Burch wrote:
> Hi everyone,
> whenever I want to setup the Ethernut build tools on a new machine, I'm
> stuck for a while with the configure error "No package 'lua' found".
> Right now, I'm trying to get a copy of Lua4 for my notebook running
> Ubuntu 16.04. But actually, I'm not even sure which version actually is
> required. Are there any plans to update the Ethernut tools to work with
> a recent Lua version that is in the usual distro packages (>=5.0)? In
> any case, I'd be glad if the configure script could output the required
> version in addition to the package name.
> Thanks and best regards,
Ok, an update, it works now and does not require Lua 4, but 5.1. To
compile qnutconf, I had to install the following packages from the
official Ubuntu repos:
lua5.1 lua5.1-0-dev qt4-default libqt4-dev
qt4-default ist important, as the MOC may otherwise generate the sources
for QT5 (or whatever the system default is), which makes the build fail.
If one develops software for QT5, it may be required to install
qt5-default after building qnutconf.
More information about the En-Nut-Discussion