[En-Nut-Discussion] http server problems

h-h.gerhard at onlinehome.de h-h.gerhard at onlinehome.de
Wed Jan 7 17:04:03 CET 2004

Hello Harald and Michel, 

I have exactly the same problem as Michel, with the "httpserv" program. 
I tried everything like Michel and all of Haralds advices. 

I installed all files (newest version from ethernut website) and I've 
used nutconf.exe. 
I copied all lib files manually to the icc\lib directory. 
I checked all options in my compiler and I checked the UserConf.mk file.

Everything seems to be correct. 

Of course I rebuilt my project and ICC didn't write anything about an 
error, just "Done." 
Flashing the "httpserv.hex" file from "c:\Ethernut\nut\appicc\httpd\" 
and verifying it went well too. 

...but like Michel already wrote, the ethernut2 board doesn't connect 
LAN, but from the COM port I receive: 

"Nut/OS HTTP Daemon...Registering device failed 
EEPROM/DHCP/ARP config failed ready" 

Theres is the right IP in the EEPROM, because if I copy the example 
"c:\Ethernut\nut\bin\atmega128\httpserv.hex" into the board, everything 
works fine, the board connects LAN, my browser shows all example 
webpages and I receive the following message through the COM port: 
"Nut/OS HTTP Daemon... ready" 

I have no glue, why it doesn't work with my self-compiled file... 

cu Nig 

P.S.: I was wrong in my last email. It just worked because I've copied 
the wrong file (the one from the bin-directory) into the ethernut 

More information about the En-Nut-Discussion mailing list