[En-Nut-Discussion] FTP server sample not working

Mark vd Waal van Dijk M.v.d.Waal_v.Dijk at krohne-altometer.nl
Wed Dec 6 15:35:46 CET 2006

Hi Harald,

I'm using Nut/OS 4.2.1. The cards were both formatted. Just to be sure I
formatted them again, but it didn't help. I can access them perfectly on my
PC though. 

The MMC card is an 4MB card from JVC, the SD is an 1GB from Panasonic. I can
try to get my hands on some other cards, maybe it has to do with the cards

Searching old posts I found someone with the same problem, he was talking
about lowering the SPI speed, does this make any sense to you? The post I'm
talking about is here: 

(3rd post made by Jix Electronics)

I cant find where to lower the SPI speed though.

Thanks again,


Harald Kipp wrote:
> Mark,
> It definitely works with all three boards. I received one
> report that it didn't work with a specific MMC from Kingston.
> Had the cards been formatted on a Win32 PC? I remember, that
> Jesper Hansen had problems with cards that didn't contain
> a partition table (Superfloppy).
> Are you using Nut/OS 4.2?
> Harald
> At 04:44 06.12.2006 -0800, you wrote:
>>The FTP sample included with the NUT/OS isn't working for me. I keep
>>the message 'Mounting partition...failed' in the Terminal. I've tried this
>>with Ethernut 3.0d, 3.0e and an AT91SAM7X-EK board (recompiled every time
>>course) I've also tried both an MMC and SD card, without success. Does
>>anyone have this sample FTP server running? Any advice on what might be
>>thanks in advance, Mark
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion

View this message in context: http://www.nabble.com/FTP-server-sample-not-working-tf2767813.html#a7720378
Sent from the MicroControllers - Ethernut mailing list archive at Nabble.com.

More information about the En-Nut-Discussion mailing list