[En-Nut-Discussion] CPLD Power-Up Problem

Harald Kipp harald.kipp at egnite.de
Tue Oct 30 11:06:36 CET 2007

One of our customers is using a custom board based on the Ethernut 2.1 
design. By using a specific power supply with a very specific voltage 
raise, the boards fails during initialization. Pulling the hardware 
reset doesn't help. Cycling just the CPLD power supply before toggling 
the hardware reset line re-awakes the board. Obviously the initial CPLD 
power-up sequence fails. On the XC9500XL series the CPLD configuration 
is loaded from EEPROM to RAM during power-up.

As the CPU is running fine, but simply fails to access external memory 
addresses, I tried to fix this problem by letting the CPU 
re-initializing the CPLD via JTAG commands. So far this never worked. 
But my JTAG code may still contain bugs.

Anyone of you experienced similar CPLD problems? Any idea, how else to 
solve this?

Btw. AFAIK the original Ethernut board does not seem to have this 
problem. At least not when using the same power supply.

Many thanks,


More information about the En-Nut-Discussion mailing list