[En-Nut-Discussion] My handmade nut does not works

Michael Jones Michael.e.Jones at web.de
Wed Jan 30 11:27:53 CET 2008


A typical "trap" is that your board might not have a "slow clock" in which
case NUT_CPU_FREQ must be set to the correct value of the main clock. This
is done with the Nut/OS Configurator under RTOS Kernel - Timer Management -
Fixed MCU clock.


-----Original Message-----
From: en-nut-discussion-bounces at egnite.de
[mailto:en-nut-discussion-bounces at egnite.de] On Behalf Of Siswanto
Sent: Wednesday, January 30, 2008 10:14 AM
To: en-nut-discussion at egnite.de
Subject: [En-Nut-Discussion] My handmade nut does not works

Dear all,
I'm newbe with RTOS, specially ethernut.
I have tried my handmade pcb with ethernut-4.4.0, WinAVR 20070525,
AVRStudio 4.13
during installations of ethernut, WinAVR and AVRStudio successfully without
warnings or errors
during examples compilation successful too, but when i burn the *.hex file
to the atmega128
target board, it is doesn't work. I have tried examples like uart, httpd,
led01, etc.

I'm sure my atmega128 target board is ok, since with AvrX RTOS works
please help me.  thanks.



More information about the En-Nut-Discussion mailing list