[En-Nut-Discussion] Ethernut 3.0 limits

Harald Kipp harald.kipp at egnite.de
Wed Jan 27 10:18:40 CET 2010

Hi Javier,

Javier Longares wrote:

> This error happens in all the OpenOCD versions I've tested both
> ready-to-install and compiled in the "funny" cygwin.  Moreover, I've saw
> that your install creates a shortcut in the "Programs" Start Menu, which
> types openocd -f ethernut3.cfg -f turtelizer2.ocd, since typing this led to
> the same error "Unknown command: daemon_startup reset"; I've tried openocd
> -f turtelizer2.cfg and the result was:

I've tried the start menu entry here and it worked immediately with
Ethernut 3 and the EIR. Possibly something got mixed up on your PC.

To make sure to start the right version, change to


and make sure you have


in your PATH. Then type

openocd -f interface\turtelizer2.cfg -f board\ethernut3.cfg

> Warn: Unable to open FTDI Device tried: 'Turtelizer JTAG/RS232 Adapter' and
> 'Turtelizer JTAG/RS232 Adapter A'
> Error: Unable to open FTDI Device tried: 'Turtelizer JTAG/RS232 Adapter' and
> 'Turtelizer JTAG/RS232 Adapter A'
> Error: ListDevices: 2
> Error: 0: "Turtelizer JTAG/RS232 Adapter' and 'Turtelizer JTAG/RS232 Adapter
> A"
> Error: 1: "Turtelizer JTAG/RS232 Adapter' and 'Turtelizer JTAG/RS232 Adapter
> B"
> Runtime error, file "command.c", line 473

Possibly not the right driver/OpenOCD version.

1. Download and install USBDeview from http://www.nirsoft.net (or any
other USB driver uninstaller of your choice).

2. Make sure that the Turtelizer is *not* connected.

3. Run USBDeview and uninstall *every* Turtelizer driver listed.

4. Quit USBDeview.

5. Unpack ftdi-turtelizer2.zip.

6. Connect the Turtelizer to the PC. The "New Hardware found" wizard
should pop up. On the second page select "from a user specified source"
or something like that (I have the German version). On the next page
select the directory where you unpacked ftdi-turtelizer2.

7. Repeat step 6 for the second driver. One is for JTAG, the other for
the USB/Serial bridge.

8. When done, try to run "Connect Ethernut 3.1" from the start menu again.

If the "New Hardware found" dialog doesn't start after connecting the
Turtelizer 2, you didn't remove all entries. Check the description
column of USBDeview.

Please let me know, if this works for you. I'll update the web page then.

And, not to forget, I'm sorry that this caused so much trouble for you.
While being so busy with other stuff, I missed to properly update our
docs in time.


More information about the En-Nut-Discussion mailing list